Facebook posting delays – resolved.

Posted

Over the past 2-3 weeks, we’ve had quite a few users email in about a range of Facebook issues: delays in posting, missing Facebook posts, posts that show up on the “Activity Feed” or the newsfeed but not on the Timeline – lots of weird stuff going on.

We tried to figure out what the problem was as things came up, but because the Timeline was still evolving in many ways, things kept breaking. And then we found out that the problem was actually related to Facebook’s privacy settings.

With the introduction of the Timeline, there were a lot of default permissions that have since changed and some 3rd party platforms integrated with Facebook inadvertently required re-authentication after Facebook’s last major release. So here’s what you have to do…

First you’ll need to go to your Facebook Privacy Settings.

 

 

 

 

 

On the subsequent page, next to “Apps and Websites” – click on Edit Settings.

 

 

 

 

 

 

 

 

Then, you’ll have to select Smashrun and manually remove each Facebook permission before clicking on “remove app” at the top.

 

 

 

 

 

Afterwards, you just log back into Smashrun, go to “settings” > Facebook > the page should prompt you to log back into Facebook and re-authorize Smashrun.

Many thanks to our Smashrunner, Mai, for giving us the heads up regarding the changes in Facebook’s old privacy settings! For any questions regarding the above, or if this doesn’t work for you, please let us know by sending us an email at hi@smashrun.com

    • Mai

      Brent –
      I un-linked my Smashrun account and then reset/re-selected all my facebook privacy settings and account settings. Not just the ones for Smashrun or in apps. For example, under “privacy” –> “How you connect”. I then re-selected all my preference. I did this for every screen in account and privacy settings and I then re-linked my Smashrun account. This seemed to fix it for me.
      Hope it helps!
      Mai

  1. Jacklyn

    argh. back to the drawing board.. we’ll take a look: what are your current FB post settings on Smashrun? and when was the last time you tried to post a run that didn’t go through? thanks!

    • Mai

      Hi Jacklyn –
      Thanks for the mention. I actually just replied to Brent’s comment too…
      I un-linked my Smashrun account and then reset/re-selected all my facebook privacy settings and account settings. Not just the ones for Smashrun or in apps. For example, under “privacy” –> “How you connect”. I then re-selected all my preference. I did this for every screen in account and privacy settings and I then re-linked my Smashrun account. This seemed to fix it for me.
      Hope this helps with diagnosing the problem further!
      ps – My runs are posting to my facebook newsfeed successfully, but I did notice that on my timeline, it doesn’t show up at the top in chronological order. It usually shows up below some other recent posts even though the date and time stamp are correct. Weird right? Has anyone else noticed that?
      Happy running!
      Mai

  2. Brent Britton

    Thanks for your attention. I left this alone for a couple months. Just now, I followed the advice above, unlinked smashrun from FB, reset every FB setting I could find that needed resetting, relinked smashrun in every possible way, and tried to post a run to my timeline, and… drumroll please… nothing. It’s not showing up. Maybe the universe is telling me to stop bragging to everyone about my mad running skillz. =]

    • Chris

      That’s so disappointing. All I can say is there are a lot of ways that something that should be so dead simple can go wrong. Every release we add more fixes and updates to the Facebook stuff. And it fixes some people. And then Facebook makes some changes, and then we need to put more fixes in place. It’s an ongoing struggle.

      On the upside we’re getting a release together now, and hopefully, maybe, crossed fingers, it’ll resolve your issues. I know this is cold comfort, but all I can say is we’re working really hard on it.